Technical Questions

Moderator: Soul_of_Shu

User avatar
Soul_of_Shu
Posts: 821
Joined: Mon Jan 11, 2021 6:48 pm

Technical Questions

Post by Soul_of_Shu »

Also of help, here is a link to a BBCode guide
ScottRoberts
Posts: 83
Joined: Wed Jan 13, 2021 9:22 pm

Re: Technical Questions

Post by ScottRoberts »

Is this the place to report bugs? If so, sometimes (not always) when one clicks on "first unread post" one is taken to the start of the last page, rather than where it should take one, somewhere in the middle of the previous page.
User avatar
Soul_of_Shu
Posts: 821
Joined: Mon Jan 11, 2021 6:48 pm

Re: Technical Questions

Post by Soul_of_Shu »

ScottRoberts wrote: Fri Apr 09, 2021 9:07 pm Is this the place to report bugs? If so, sometimes (not always) when one clicks on "first unread post" one is taken to the start of the last page, rather than where it should take one, somewhere in the middle of the previous page.
Hi Scott .... I can't say that I've noticed this glitch, but perhaps Simon has some answer. I've sent him an email, just in case he hasn't checked in here.
Here out of instinct or grace we seek
soulmates in these galleries of hieroglyph and glass,
where mutual longings and sufferings of love
are laid bare in transfigured exhibition of our hearts,
we who crave deep secrets and mysteries,
as elusive as the avatars of our dreams.
Simon Adams
Posts: 368
Joined: Fri Nov 13, 2020 10:54 pm

Re: Technical Questions

Post by Simon Adams »

ScottRoberts wrote: Fri Apr 09, 2021 9:07 pm Is this the place to report bugs? If so, sometimes (not always) when one clicks on "first unread post" one is taken to the start of the last page, rather than where it should take one, somewhere in the middle of the previous page.
I hadn’t noticed that, but I can see it’s a fairly common problem (eg. here https://www.phpbb.com/community/viewtopic.php?t=2397221 )

I’ve made a small change to the cookie that may help. It may force people to login again (sorry!) but there is a chance that it could help with this one. If it doesn’t force you to log in again, can you log out and then log in again and see if you have the same problem?

Can you let me know one way or the other Scott?
Ideas are certain original forms of things, their archetypes, permanent and incommunicable, which are contained in the Divine intelligence. And though they neither begin to be nor cease, yet upon them are patterned the manifold things of the world that come into being and pass away.
St Augustine
ScottRoberts
Posts: 83
Joined: Wed Jan 13, 2021 9:22 pm

Re: Technical Questions

Post by ScottRoberts »

Simon Adams wrote: Sat Apr 10, 2021 1:14 pm
ScottRoberts wrote: Fri Apr 09, 2021 9:07 pm Is this the place to report bugs? If so, sometimes (not always) when one clicks on "first unread post" one is taken to the start of the last page, rather than where it should take one, somewhere in the middle of the previous page.
I hadn’t noticed that, but I can see it’s a fairly common problem (eg. here https://www.phpbb.com/community/viewtopic.php?t=2397221 )

I’ve made a small change to the cookie that may help. It may force people to login again (sorry!) but there is a chance that it could help with this one. If it doesn’t force you to log in again, can you log out and then log in again and see if you have the same problem?

Can you let me know one way or the other Scott?
I did indeed find myself logged out. Logged in, but found the problem still exists: the "first unread post" took me to the top of page 2 of the "Why does it matter" thread, but I had not seen the last post on page 1. The link worked correctly on all the other topics. (Not that this helps, since everyone's "first unread post" is different and changes on each viewing. )

Could this have anything to do with the fact that I use two different computers? That is, I use a tablet when I am just catching up on the threads, but move to a laptop if I want to post something (can't stand typing on a tablet).

Anyway, this is, for me, just a little inconvenience, so no big deal if it can't be fixed. But I will keep an eye out for any pattern I can discover.
Simon Adams
Posts: 368
Joined: Fri Nov 13, 2020 10:54 pm

Re: Technical Questions

Post by Simon Adams »

ScottRoberts wrote: Sat Apr 10, 2021 9:33 pm
I did indeed find myself logged out. Logged in, but found the problem still exists: the "first unread post" took me to the top of page 2 of the "Why does it matter" thread, but I had not seen the last post on page 1. The link worked correctly on all the other topics. (Not that this helps, since everyone's "first unread post" is different and changes on each viewing. )

Could this have anything to do with the fact that I use two different computers? That is, I use a tablet when I am just catching up on the threads, but move to a laptop if I want to post something (can't stand typing on a tablet).

Anyway, this is, for me, just a little inconvenience, so no big deal if it can't be fixed. But I will keep an eye out for any pattern I can discover.
That could be the problem, as several of the posts on this issue suggest that the ‘read’ status is stored in the browser cache. However the configuration is set for it to be kept on the server, so in theory it shouldn’t matter what browser you’re using.

What I have done is cleared the cache on the server which may help, but I’ll do a bit more research on exactly how it works which may help give us a better clue about what is happening...
Ideas are certain original forms of things, their archetypes, permanent and incommunicable, which are contained in the Divine intelligence. And though they neither begin to be nor cease, yet upon them are patterned the manifold things of the world that come into being and pass away.
St Augustine
ScottRoberts
Posts: 83
Joined: Wed Jan 13, 2021 9:22 pm

Re: Technical Questions

Post by ScottRoberts »

Simon,

I think I've got a testable scenario for the "first unread post" bug, but I can't test it without creating a new user, and without cluttering the forum with a test, so I thought I would pass the buck to you, and if it tests out, you can send it to the forum software folks. If you want, of course -- as I said, it is only a minor inconvenience. Anyway, the bug seems to consistently occur when on day 1 there are less than ten posts, hence all on page 1. Then on day 2 there are more than 10 posts, so the topic has gone to page 2. The "first unread post" will take me to the top of page 2, thus skipping the last few posts on page 1. This only seems to happen when going from page 1 to page 2, and not with later pages. Hope this helps.
Simon Adams
Posts: 368
Joined: Fri Nov 13, 2020 10:54 pm

Re: Technical Questions

Post by Simon Adams »

ScottRoberts wrote: Fri May 07, 2021 9:41 pm Simon,

I think I've got a testable scenario for the "first unread post" bug, but I can't test it without creating a new user, and without cluttering the forum with a test, so I thought I would pass the buck to you, and if it tests out, you can send it to the forum software folks. If you want, of course -- as I said, it is only a minor inconvenience. Anyway, the bug seems to consistently occur when on day 1 there are less than ten posts, hence all on page 1. Then on day 2 there are more than 10 posts, so the topic has gone to page 2. The "first unread post" will take me to the top of page 2, thus skipping the last few posts on page 1. This only seems to happen when going from page 1 to page 2, and not with later pages. Hope this helps.
Hi Scott

Sorry I only just saw this. That's the trouble with mostly using the forum via my phone. It's only because I was on here to try and add a plugin to autosave drafts - hence on my laptop - that I noticed it.

That's really useful info... I'll see if I can replicate it, and the report it to the PBPBB gang...
Ideas are certain original forms of things, their archetypes, permanent and incommunicable, which are contained in the Divine intelligence. And though they neither begin to be nor cease, yet upon them are patterned the manifold things of the world that come into being and pass away.
St Augustine
Simon Adams
Posts: 368
Joined: Fri Nov 13, 2020 10:54 pm

Re: Technical Questions

Post by Simon Adams »

Hi Scott

Apologies for the delay, I’ve been a bit busy but have a couple of days off now. I have raised this with the developers/support team and none of them have any idea about what is happening. At least that means I wasn’t missing anything obvious.

As they haven’t heard of it before, it’s possible it relates to the default theme or one of the extensions we’re using. I have pruned all the main elements of the databases, but if that hasn’t worked we have three things left that we can try;

1) I have allowed people to change to the default “prosilver” theme in the user control panel (under board settings). You could try this and see if it helps.
2) We could disable all the extensions to see if this helps. This would be fairly high impact to people using the forum during this time (digests will stop working, will be more difficult to create inline content such as videos and links etc), but I’m happy to try it if everyone else is.
3) I think I’ve been able to recreate the problem once, but my reading tends to be a bit random and it’s tricky to test when you’re using the board but don’t naturally use the ‘goto last read post’ option. So I could create a separate, temporary test forum. This may be an easier way to test 2) anyway.

Anyway can you try change to the built in ‘prosilver’ theme for a while to see if that fixes it, as that should be an easier one to rule out. If not we can try to rule out the others in a way that keeps the impact to everyone else to a minimum.
Ideas are certain original forms of things, their archetypes, permanent and incommunicable, which are contained in the Divine intelligence. And though they neither begin to be nor cease, yet upon them are patterned the manifold things of the world that come into being and pass away.
St Augustine
ScottRoberts
Posts: 83
Joined: Wed Jan 13, 2021 9:22 pm

Re: Technical Questions

Post by ScottRoberts »

Simon Adams wrote: Tue Jun 01, 2021 7:46 am Hi Scott

Apologies for the delay, I’ve been a bit busy but have a couple of days off now. I have raised this with the developers/support team and none of them have any idea about what is happening. At least that means I wasn’t missing anything obvious.

As they haven’t heard of it before, it’s possible it relates to the default theme or one of the extensions we’re using. I have pruned all the main elements of the databases, but if that hasn’t worked we have three things left that we can try;

1) I have allowed people to change to the default “prosilver” theme in the user control panel (under board settings). You could try this and see if it helps.
2) We could disable all the extensions to see if this helps. This would be fairly high impact to people using the forum during this time (digests will stop working, will be more difficult to create inline content such as videos and links etc), but I’m happy to try it if everyone else is.
3) I think I’ve been able to recreate the problem once, but my reading tends to be a bit random and it’s tricky to test when you’re using the board but don’t naturally use the ‘goto last read post’ option. So I could create a separate, temporary test forum. This may be an easier way to test 2) anyway.

Anyway can you try change to the built in ‘prosilver’ theme for a while to see if that fixes it, as that should be an easier one to rule out. If not we can try to rule out the others in a way that keeps the impact to everyone else to a minimum.
I switched to 'prosilver', but alas the problem is still there. But it is easy to work around, so I wouldn't go to the extreme of option (2).
Post Reply